Tasks:
Configure routers so that R2 will be the default router for whole network and it will originate default information to whole network but only on speciified interfaces.

In this case we wanna send default network to R1 but not to R3.
!R1 configuration
interface Loopback0
 ip address 10.1.1.1 255.0.0.0
!
interface Serial0/0
 ip address 1.1.1.1 255.0.0.0
no shut
!
router rip
 version 2
 network 1.0.0.0
 network 10.0.0.0


!R2 configuration
interface Serial0/0
 ip address 1.1.1.2 255.0.0.0
 no shut
!
interface Serial0/1
 ip address 2.2.2.1 255.0.0.0
no shut
!
router rip
 version 2
 network 1.0.0.0
 network 2.0.0.0
 default-information originate route-map stop-default



route-map stop-default
 set interface Serial0/1



!R3 configuration
interface Serial0/0
 ip address 2.2.2.2 255.0.0.0
 no shut
!
router rip
 version 2
 network 2.0.0.0
Explanation


























Applying route map to send default information originate. Now default information will only be sent to interface specified in route map

Creating route map

setting interface in the route map
 
Task:
Configure routers so that R2 will only originate default information to R3; if 10.1.1.1 is available
!R1 configuration
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 1.1.1.1 255.0.0.0
no shut
!
router rip
 version 2
 network 1.0.0.0
 network 10.0.0.0
no auto-summary


!R2 configuration
interface Serial0/0
 ip address 1.1.1.2 255.0.0.0
 no shut
!
interface Serial0/1
 ip address 2.2.2.1 255.0.0.0
no shut
!
router rip
 version 2
 network 1.0.0.0
 network 2.0.0.0
 default-information originate route-map match-10


access-list 10 permit 10.1.1.1

route-map match-10
 match ip address 10
 set interface Serial0/1


!R3 configuration

interface Serial0/0
 ip address 2.2.2.2 255.0.0.0
 no shut
!
router rip
 version 2
 network 2.0.0.0





























This command let us do conditional routing as it matches route map name "match-10".

Created Access List 10

Created Route map 10
if ip address in access list 10 matched then interface will be set.
 
Tasks:
Configure ip addresses as per topology
Configure Rip on all networks

R3 will forward all routes to R5 by adding 10 in metric except network 1.1.1.0
R1 will change metric for 4.4.4.0 to 5 for R4 and 8 for R2
Verify results by:
show ip route
! R1 Configuration
interface Serial0/0
 ip address 1.1.1.1 255.255.255.252
no shut

interface Serial0/1
 ip address 3.3.3.1 255.255.255.252
no shut

interface Serial0/2
 ip address 2.2.2.1 255.255.255.252
no shutdown

router rip
 version 2
 offset-list 1 out 5 Serial0/1



 offset-list 1 out 8 Serial0/2

 network 1.0.0.0
 network 2.0.0.0
 network 3.0.0.0
 no auto-summary

access-list 1 permit 4.4.4.0 0.0.0.255



! R2 Configuration
interface Serial0/0
 ip address 2.2.2.2 255.255.255.252
 no shut

router rip
 version 2
 network 2.0.0.0
 no auto-summary



! R3 Configuration
interface Serial0/0
 ip address 1.1.1.2 255.255.255.252
no shut
!
interface Serial0/1
 ip address 4.4.4.1 255.255.255.252
no shut
!
router rip
 version 2
 offset-list 1 out 10 Serial0/1


 network 1.0.0.0
 network 4.0.0.0
 no auto-summary
!
access-list 1 deny   1.1.1.0 0.0.0.255
access-list 1 permit 0.0.0.0 3.3.3.255


! R4 Configuration
interface Serial0/0
 ip address 3.3.3.2 255.255.255.252
 no shut
!
router rip
 version 2
 network 3.0.0.0
 no auto-summary



! R5 Configuration
interface Serial0/0
 ip address 4.4.4.2 255.255.255.252
 no shut
!
router rip
 version 2
 network 4.0.0.0
 no auto-summary
Explanation
IP addresses configured on interface



IP address configured on interface



IP address configured on interface



Configuring Rip

Manipulating metric by 5 by using access list 1. Offset list is applied when information gets out of an interface


Manipulating metric by 8 by using access list 1. Offset list is applied when information gets out of an interface





Access list 1 created


























Manipulating metric by 10 hops by using access list 1. Offset list is applied when information gets out of an interface





Access list 1 created
 
passive-interface command is used to block RIP broadcasts on an interface connected to a subnet of a RIP-enabled network. In simple words, Passive-interface command is used in all routing protocols to disable sending updates out from a specific interface. A RIP Passive Interface in a nut shell prevents the RIP routing process from sending multicast/broadcast updates out a specified interface. A RIP Passive interface however does not block unicast updates. Keep in mind a Passive Interface DOES NOT block multicast/broadcast updates therefore the router would still process received RIP updates
Tasks:
Configure IP addresses as per diagram
Configure Rip on all networks
Configure R3 Fast Ethernet 0/0 interface to start Rip unicast
Debug by using following commands.
show ip route
show ip route rip
sh ip protocol
debug ip rip events
debug ip rip database

! R1 Configuration

interface Loopback0
ip address 20.1.2.1 255.255.255.255

interface FastEthernet0/0
ip address 1.1.1.10 255.255.255.0
no shut

router rip
version 2
network 1.0.0.0
network 20.0.0.0
no auto-summary


! R2 Configuration

interface Loopback0
ip address 20.1.1.1 255.255.255.255

interface FastEthernet0/0
ip address 1.1.1.20 255.255.255.0
no shut

router rip
version 2
network 1.0.0.0
network 20.0.0.0
no auto-summary


! R3 Configuration

interface Loopback0
ip address 30.1.1.1 255.255.255.255

interface Loopback1
ip address 30.1.2.1 255.255.255.255

interface FastEthernet0/0
ip address 1.1.1.30 255.255.255.0
no shut

router rip
version 2
passive-interface FastEthernet0/0
network 1.0.0.0
network 30.0.0.0
neighbor 1.1.1.20
no auto-summary

Explanation














































Configuring Passive
interface on F0/0 of Router 3
 
Task 1: Use simple authentication between R1 and R2. Key is simplekey
Task 2: Use md5 authentication between R3 and R2. Key is md5key

Debug to verify results

hostname R1


key chain simple
key 1
key-string simplekey

interface Loopback0
ip address 10.1.1.1 255.255.255.255
interface Loopback1
ip address 10.1.1.2 255.255.255.255

interface Serial0/0
no shut
ip address 1.1.1.1 255.255.255.252
ip rip authentication key-chain simple
clock rate 64000

router rip
version 2
network 1.0.0.0
network 10.0.0.0




hostname R2

key chain simple
key 1
key-string simplekey

key chain md5
key 1
key-string md5key

interface Serial0/0
no shut
ip address 1.1.1.2 255.255.255.252
ip rip authentication key-chain simple

interface Serial0/1
no shut
ip address 2.2.2.1 255.255.255.252
ip rip authentication mode md5

ip rip authentication key-chain md5

router rip
version 2
network 1.0.0.0
network 2.0.0.0



hostname R3
key chain md5
key 1
key-string md5key

interface Serial0/0
no shut
ip address 2.2.2.2 255.255.255.252
ip rip authentication mode md5

ip rip authentication key-chain md5
clock rate 64000


router rip
version 2
network 2.0.0.0


Explanation


Key chain name defined
Key chain's key defined
Key's password or string defined forsimple authentication between R1 and R2








Authentication defined on serial interface. Authenticated keychain is "simple"












Keychain defined for simple authentication



Key chain defined for encrypted authentication
i.e. MD5






Key chain named "simple" applied between R1 and R2




Encrypted Authentication applied on interface between R2 and R3
Authentication key chain applied










Encrypted key chain defined named md5.






Encrypted Authentication applied on interface between R2 and R3
Authentication key chain applied
 
Requirement:
  • Configure IP addresses as per diagram
  • Configure loopback addresses as per diagram
  • All routers must reach every route in the network
  • How many virtual links and tunnels we need to configure for this topology so that R8 will have all routes and why?
    1. 1 virtual link
    2. 2 virtual link
    3. 1 virtual link and 1 tunnel
    4. More then 2 virtual links
  • Test connectivity by ping
  • How many pings do we need to reach all networks from R8? Can pinging 255.255.255.255 will help us reach all networks in one go? If yes Why and If no then why not?
  • Verify configuration by using following commands
    1. Show ip route
    2. show ip eigrp interfaces
    3. show ip eigrp neighbors
    4. show ip eigrp topology
    5. show ip eigrp traffic
    6. show ip protocol
    7. show ip ospf border-routers
    8. show ip ospf database
    9. show ip ospf interface
    10. show ip ospf neighbor
    11. show ip ospf virtual-links
    12. show ip rip database
! R1 configuration

interface Loopback0
 ip address 10.1.1.1 255.255.255.0
no shut

interface Loopback1
 ip address 10.1.2.1 255.255.255.0
no shut

interface FastEthernet0/0
 ip address 7.7.7.2 255.255.255.252
no shut

interface Serial0/0
 ip address 1.1.1.1 255.255.255.252
no shut

router eigrp 100
 network 1.0.0.0
 network 10.0.0.0
 no auto-summary

router ospf 1
 network 7.7.7.0 0.0.0.3 area 0




! R3 configuration

interface Loopback5
 ip address 30.1.1.1 255.255.255.0

interface Loopback6
 ip address 30.1.30.1 255.255.255.0

interface FastEthernet0/1
 ip address 6.6.6.2 255.255.255.252
no shut

interface Serial0/1
 ip address 3.3.3.1 255.255.255.252
no shut

router eigrp 100
 redistribute rip metric 10 10 10 10 10
 redistribute ospf 1 metric 10 10 10 10 10
 network 3.0.0.0
 no auto-summary

router ospf 1
 redistribute eigrp 100 metric 10 subnets
 redistribute rip metric 10 subnets
 network 6.6.6.0 0.0.0.3 area 0

router rip
 version 2
 redistribute eigrp 100 metric 10
 redistribute ospf 1 metric 10
 network 2.0.0.0
 network 30.0.0.0
 no auto-summary


! R5 configuration

interface Loopback59
 ip address 59.1.1.1 255.255.255.0

interface Loopback69
 ip address 69.1.1.1 255.255.255.0

interface Loopback79
 ip address 79.1.1.1 255.255.255.0

interface Serial0/0
 ip address 5.5.5.2 255.255.255.252
no shut

interface Serial0/1
 ip address 4.4.4.2 255.255.255.252
no shut

router ospf 1
 area 1 virtual-link 40.1.40.1
 network 4.4.4.0 0.0.0.3 area 1
 network 5.5.5.0 0.0.0.3 area 0
 network 59.1.1.0 0.0.0.255 area 0
 network 69.1.1.0 0.0.0.255 area 0
 network 79.1.1.0 0.0.0.255 area 1







! R7 configuration

interface FastEthernet0/0
 ip address 200.1.1.2 255.255.255.252
no shut

interface Serial0/0
 ip address 210.1.1.1 255.255.255.252
 clock rate 64000
no shut

router ospf 1
 log-adjacency-changes
 area 2 virtual-link 40.1.40.1
 network 200.1.1.0 0.0.0.3 area 2
 network 210.1.1.0 0.0.0.3 area 3
! R2 configuration

interface Loopback9
 ip address 20.1.1.1 255.255.255.0

interface Loopback10
 ip address 20.1.10.1 255.255.255.0

interface Serial0/0
 ip address 1.1.1.2 255.255.255.252
no shut

interface Serial0/1
 ip address 2.2.2.1 255.255.255.252
no shut

router eigrp 100
 redistribute rip metric 10 10 10 10 10
 network 1.0.0.0
 network 20.0.0.0
 no auto-summary

router rip
 version 2
 redistribute eigrp 100 metric 10
 network 2.0.0.0
 no auto-summary


! R4 configuration

interface Loopback100
 ip address 40.1.1.1 255.255.255.0

interface Loopback101
 ip address 40.1.40.1 255.255.255.0

interface FastEthernet0/0
 ip address 200.1.1.1 255.255.255.252
no shut

interface Serial0/0
 ip address 3.3.3.2 255.255.255.252
no shut

interface Serial0/1
 ip address 4.4.4.1 255.255.255.252
no shut

router eigrp 100
 network 3.0.0.0
 network 40.0.0.0
 no auto-summary

router ospf 1
 area 1 virtual-link 79.1.1.1
 area 2 virtual-link 210.1.1.1
 network 4.4.4.0 0.0.0.3 area 1
 network 200.1.1.0 0.0.0.3 area 2






! R6 configuration

interface Loopback59
 ip address 130.0.0.1 255.255.255.0

interface Loopback69
 ip address 140.0.0.1 255.255.255.0

interface Loopback89
 ip address 150.0.0.1 255.255.255.0

interface FastEthernet0/0
 ip address 7.7.7.1 255.255.255.252
no shut

interface Serial0/0
 ip address 5.5.5.1 255.255.255.252
 clock rate 64000
no shut

interface FastEthernet0/1
 ip address 6.6.6.1 255.255.255.252
no shut

router ospf 1
 network 5.5.5.0 0.0.0.3 area 0
 network 6.6.6.0 0.0.0.3 area 0
 network 7.7.7.0 0.0.0.3 area 0
 network 130.0.0.0 0.0.0.255 area 0
 network 140.0.0.0 0.0.0.255 area 1
 network 150.0.0.0 0.0.0.255 area 0


! R8 configuration

interface Serial0/0
 ip address 210.1.1.2 255.255.255.252
no shut

router ospf 1
 network 210.1.1.0 0.0.0.3 area 3
 
Picture
Requirement:
  1. Configure IP addresses as given
  2. Configure discontigeous networks on router 1 and router 3 loopback 0.
  3. Run Rip version 2 on all routers
  4. Check if both Discontigeous networks are reachable from router 6. We will ping both networks and you will see results.

Router 1 configuration

R1(config)#interface Loopback0
R1(config-if)# ip address 200.100.100.1 255.255.255.128

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 1.1.1.1 255.255.255.252
R1(config-if)# no shutdown

R1(config)#router rip
 R1(config-router)#version 2
R1(config-router)#no auto-summary
 R1(config-router)#network 1.0.0.0
 R1(config-router)#network 200.100.100.0


Router 2 configuration

R2(config)# interface FastEthernet0/0
 R2(config-if)#ip address 1.1.1.2 255.255.255.252
  R2(config-if)# no shutdown

R2(config)# interface FastEthernet0/1
  R2(config-if)#ip address 2.2.2.1 255.255.255.252
  R2(config-if)#no shutdown

R2(config)# interface FastEthernet1/0
  R2(config-if)#ip address 3.3.3.1 255.255.255.252
  R2(config-if)#speed 100
  R2(config-if)#duplex full
R2(config-if)#no shutdown

R2(config)# router rip
  R2(config-router)#version 2
R2(config-router)#no auto-summary
 R2(config-router)#network 1.0.0.0
 R2(config-router)#network 2.0.0.0
 R2(config-router)#network 3.0.0.0


R1# show ip protocols
Router 3 configuration

R3(config)#interface Loopback0
R1(config-if)# ip address 200.100.100.150 255.255.255.128

R3(config)#interface FastEthernet0/0
R3(config-if)# ip address 2.2.2.2 255.255.255.252
R3(config-if)#no shutdown

R3(config)#router rip
 R3(config-router)#version 2
R3(config-router)#no auto-summary
 R3(config-router)#network 2.0.0.0
 R3(config-router)#network 200.100.100.0


Router 6 configuration

R6(config)#interface FastEthernet0/0
 R6(config-if)#ip address 3.3.3.2 255.255.255.252
R6(config-if)# speed 100
R6(config-if)# full-duplex
R6(config-if)#no shutdown

R6(config)# ip route 0.0.0.0 0.0.0.0 3.3.3.1
R2# Show ip route
Here we ping from Router 6 to R1 and R3 loopback interfaces ip addresses ( which are discontigeous). Let see results. From undermentioned ping images, we have found that ping to 200.100.100.150 and  200.100.100.1 is successful.
Compare both Trace routes. You will find that 2nd Hop of both routes are different
Compare both Trace routes. You will find that 2nd Hop of both routes are different